aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules53
1 files changed, 0 insertions, 53 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index 1a67696..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/usr/bin/make -f
-# Made with the aid of debmake, by Christoph Lameter,
-# based on the sample debian/rules file for GNU hello by Ian Jackson.
-
-package=dictionary
-
-build:
- $(checkdir)
-
- touch build
-
-clean:
- $(checkdir)
- -rm -f build
- -rm -f `find . -name "*~"`
- -rm -rf debian/tmp debian/files* core debian/substvars
-
-binary-indep: checkroot build
- $(checkdir)
-# There are no architecture-independent files to be uploaded
-# generated by this package. If there were any they would be
-# made here.
-
-binary-arch: checkroot build
- $(checkdir)
- -rm -rf debian/tmp
- install -d debian/tmp
- cd debian/tmp && install -d `cat ../dirs`
-
- cp dictionary.el connection.el link.el dictionary-init.el \
- debian/tmp/usr/share/emacs/site-lisp
- cp debian/install.debian debian/tmp/usr/lib/emacsen-common/packages/install/dictionary
- chmod 755 debian/tmp/usr/lib/emacsen-common/packages/install/dictionary
- cp debian/remove.debian debian/tmp/usr/lib/emacsen-common/packages/remove/dictionary
- chmod 755 debian/tmp/usr/lib/emacsen-common/packages/remove/dictionary
-
- debstd README
- dpkg-gencontrol -isp
- chown -R root.root debian/tmp
- chmod -R go=rX debian/tmp
- dpkg --build debian/tmp ..
-
-define checkdir
- test -f debian/rules
-endef
-
-binary: binary-indep binary-arch
-
-checkroot:
- $(checkdir)
- test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot