aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorforcer <forcer>2007-06-29 16:10:00 +0000
committerforcer <mwolson@gnu.org>2007-06-29 16:10:00 +0000
commit049e877c3bd23c0ab184c5cbe029b7ebd9f09d58 (patch)
treeb265409fea34cef23b37d0f9797b7b23d60f2363 /debian/rules
parent9463aa0abef27e2d9fda07669a165410e713d0d7 (diff)
Remove debian directory, it's maintained elsewhere now
darcs-hash:20070629161023-2189f-8e01f6cbc23c40df3e4bf3c79182728fae659f86.gz
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules97
1 files changed, 0 insertions, 97 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index fdd116f..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- # Add here commands to configure the package.
-
- touch configure-stamp
-
-
-build: build-arch
-build-arch: build-arch-stamp
-build-arch-stamp:
- make emms-print-metadata
- touch build-arch-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-arch-stamp configure-stamp
-
- # Add here commands to clean up after the build process.
- -$(MAKE) clean
-
- dh_clean
-
-install: install-arch
-install-arch:
- dh_testdir
- dh_testroot
- dh_clean -k -s
- dh_installdirs -s
-
- # Add here commands to install the arch part of the package into
- # debian/emms
- make emms.info
- make emms-auto.el
- $(MAKE) deb-install DESTDIR=$(CURDIR)/debian/emms PREFIX=$(CURDIR)/debian/emms/usr
- install emms-print-metadata debian/emms/usr/bin/
-
- dh_install -s
-
-# Must not depend on anything. This is to be called by
-# binary-arch/binary-indep
-# in another 'make' thread.
-binary-common:
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
-# dh_installexamples
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
- dh_installemacsen
- dh_installinfo
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
- dh_installman emms-print-metadata.1
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
-# dh_perl
-# dh_python
-# dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-# Build architecture dependant packages using the common target.
-binary-arch: build-arch install-arch
- $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
-
-binary: binary-arch
-.PHONY: build clean binary-arch binary install configure